What’s Vulnerable › Vulnerabilities
CVE-2026-102409: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-13
- Weakness: CWE-674
Description
Uncontrolled Recursion (CWE-674) in Elasticsearch can allow an authenticated user with low privileges to terminate an Elasticsearch node, resulting in denial of service, via Excessive Allocation (CAPEC-130).
Affected products
- Elasticsearch: from 9.2.0 before 9.4.8; from 9.5.0 before 9.5.5 — fixed in 9.4.8, 9.5.5
How to fix
Upgrade to a fixed version: Elasticsearch 9.4.8, 9.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-102409 or the next vulnerability affects your stack