What’s Vulnerable › Vulnerabilities
CVE-2026-102460
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-20
- Weakness: CWE-863
Description
In Eclipse Vert.x versions [4.0.0, 4.5.34] or [5.0.0,5.0.12] or [5.1.0,5.1.9] or [5.2.0, 5.2.0], a scope bypass vulnerability exists in Eclipse Vert.x Web's ChainAuthHandler when used with scope-requiring authentication handlers such as JWTAuthHandler or OAuth2AuthHandler. When a user is already authenticated on the routing context by a preceding handler in the request pipeline, ChainAuthHandler skips all scope validation configured via withScope() or withScopes(). This affects both any() and all() chain modes. The root cause is that postAuthentication() relies on internal state that is only set during the authenticate() phase, which is skipped entirely for pre-authenticated users. In any() mode, the absence of this state causes the method to fall through without delegating scope checks to any handler. In all() mode, scope checks are unconditionally skipped. This allows a user with a valid token but insufficient scopes to access resources protected by scope requirements, provided they were authenticated by an earlier handler in the pipeline. The most common trigger is overlapping authentication handlers on nested routes, where a parent route authenticates broadly and a child route uses a chain to enforce specific scopes. The impacted component Maven coordinate is io.vertx:vertx-web
Affected products
- Eclipse Foundation Eclipse Vert.x: from 4.5.0 before 4.5.35; from 5.0.0 before 5.1.10; 5.2.0 — fixed in 4.5.35, 5.1.10
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Vert.x 4.5.35, 5.1.10. Check the vendor advisory for mitigations.
References
- https://github.com/vert-x3/vertx-web/security/advisories/GHSA-2p39-cr56-w58j
- https://gitlab.eclipse.org/security/cve-assignment/-/work_items/339
Get alerted when CVE-2026-102460 or the next vulnerability affects your stack