What’s Vulnerable › Vulnerabilities
CVE-2026-102478
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-1289
Description
In affected versions of Octopus Server, an authenticated user with permission to modify roles could bypass the protections preventing access abuse resulting in privilege escalation. It was possible for the built-in role to be weakened and the attacker's account added to a privileged team. This was achievable due to improper validation of unsafe equivalence in inputs.
Affected products
- Octopus Deploy Octopus Server: from 2023.2.945 before 2026.1.11768; from 2026.2.0 before 2026.2.13408; from 2026.3.0 before 2026.3.15816 — fixed in 2026.1.11768, 2026.2.13408, 2026.3.15816
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2026.1.11768, 2026.2.13408, 2026.3.15816. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-102478 or the next vulnerability affects your stack