What’s Vulnerable › Vulnerabilities
CVE-2026-102488
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-863
Description
In affected versions, Octopus Server incorrectly evaluates multiple scoped permission assignments, allowing a highly privileged user to obtain deployment permissions beyond those actually granted to them.
Affected products
- Octopus Deploy Octopus Server: from 2019.5.0 before 2026.2.12438; from 2026.3.0 before 2026.3.15816 — fixed in 2026.2.12438, 2026.3.15816
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2026.2.12438, 2026.3.15816. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-102488 or the next vulnerability affects your stack