What’s Vulnerable › Vulnerabilities
CVE-2026-102495: Apache XMLSchema: Denial of service through unbounded recursion when resolving schema imports and includes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-10-06
- Weakness: CWE-674
Description
Apache XmlSchema doesn't limit how deeply schema imports and includes can be nested, so a malicious schema can make parsing recurse until the stack overflows. This causes a denial of service. Users are recommended to upgrade to version 2.3.3, which fixes this issue.
Affected products
- Apache Software Foundation Apache XMLSchema: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache XMLSchema 2.3.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/l339q3oldm0cd2lph4b6f93fd07x9g6s
- http://www.openwall.com/lists/oss-security/2026/09/29/15
Get alerted when CVE-2026-102495 or the next vulnerability affects your stack