What’s Vulnerable › Vulnerabilities
CVE-2026-102578: Moodle: sql injection in question bank web service
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-01
- Weakness: CWE-89
Description
A flaw was found in Moodle. An authenticated attacker with access to the question bank web service can submit unsanitized input directly into database queries, resulting in a SQL (Structured Query Language) injection vulnerability. This issue could allow an attacker to view, alter, or delete sensitive data stored in the underlying database.
Affected products
- Moodle: before 4.5.13; from 5.0.0 before 5.0.9; from 5.1.0 before 5.1.6; from 5.2.0 before 5.2.2 — fixed in 4.5.13, 5.0.9, 5.1.6, 5.2.2
How to fix
Upgrade to a fixed version: Moodle 4.5.13, 5.0.9, 5.1.6, 5.2.2. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-89383
- https://access.redhat.com/security/cve/CVE-2026-102578
- https://bugzilla.redhat.com/show_bug.cgi?id=2543632
- https://moodle.org/mod/forum/discuss.php?d=482496
Get alerted when CVE-2026-102578 or the next vulnerability affects your stack