What’s Vulnerable › Vulnerabilities
CVE-2026-102581: Moodle: xss in forum post templates due to insufficient escaping
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-01
- Weakness: CWE-79
Description
A flaw was found in Moodle. Insufficient output escaping in templates used to display forum posts enables a stored cross-site scripting (XSS) vulnerability. An attacker can inject malicious content into a forum post, which then executes arbitrary script code in the browser of another user viewing the affected post.
Affected products
- Moodle: before 4.5.13; from 5.0.0 before 5.0.9; from 5.1.0 before 5.1.6; from 5.2.0 before 5.2.2 — fixed in 4.5.13, 5.0.9, 5.1.6, 5.2.2
How to fix
Upgrade to a fixed version: Moodle 4.5.13, 5.0.9, 5.1.6, 5.2.2. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-88981
- https://access.redhat.com/security/cve/CVE-2026-102581
- https://bugzilla.redhat.com/show_bug.cgi?id=2543634
- https://moodle.org/mod/forum/discuss.php?d=482499
Get alerted when CVE-2026-102581 or the next vulnerability affects your stack