What’s Vulnerable › Vulnerabilities
CVE-2026-102583: Moodle: incorrect capability check in ai generate image web service
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-01
- Weakness: CWE-425
Description
A flaw was found in Moodle. An incorrect capability check in the artificial intelligence (AI) editor placement's image generation web service allows an authenticated user to invoke the feature without holding the required capability. This flaw permits unauthorized users to access and utilize the AI image generation functionality.
Affected products
- Moodle: before 4.5.13; from 5.0.0 before 5.0.9; from 5.1.0 before 5.1.6; from 5.2.0 before 5.2.2 — fixed in 4.5.13, 5.0.9, 5.1.6, 5.2.2
How to fix
Upgrade to a fixed version: Moodle 4.5.13, 5.0.9, 5.1.6, 5.2.2. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-88587
- https://access.redhat.com/security/cve/CVE-2026-102583
- https://bugzilla.redhat.com/show_bug.cgi?id=2543640
- https://moodle.org/mod/forum/discuss.php?d=482501
Get alerted when CVE-2026-102583 or the next vulnerability affects your stack