What’s Vulnerable › Vulnerabilities
CVE-2026-102603: Gotify: Insufficiently Protected Password Change endpoint
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-16
- Weakness: CWE-620
Description
Gotify server is a simple server for sending and receiving messages in real-time per WebSocket. Prior to 3.0.0, the password change endpoint (POST /current/user/password) accepts a valid client token without requiring the account's current password or another elevated authentication step. An attacker who obtains a client token can set a new password for the associated user, taking control of password authentication and forcing account recovery through an administrator or direct database access. This issue is fixed in version 3.0.0.
Affected products
- gotify server: before 3.0.0
References
- https://github.com/gotify/server/commit/a8744482c668e07a61798573ec8e17bd3f6009f9
- https://github.com/gotify/server/pull/952
- https://github.com/gotify/server/releases/tag/v3.0.0
- https://github.com/gotify/server/security/advisories/GHSA-3hcj-9m7p-wwm9
- https://github.com/gotify/server/security/advisories/GHSA-3hcj-9m7p-wwm9
Get alerted when CVE-2026-102603 or the next vulnerability affects your stack