What’s Vulnerable › Vulnerabilities
CVE-2026-102827: simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-29 · updated 2026-10-08
- Weakness: CWE-77
Description
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.
Affected products
- simple-git: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: simple-git 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/steveukx/git-js/commit/98864c678444d9336357c844efa4fd5a7984c0d7
- https://github.com/steveukx/git-js/pull/1193
- https://github.com/steveukx/git-js/releases/tag/simple-git@4.0.0
- https://github.com/steveukx/git-js/security/advisories/GHSA-858h-whjf-mvg5
Get alerted when CVE-2026-102827 or the next vulnerability affects your stack