What’s Vulnerable › Vulnerabilities
CVE-2026-102828: simple-git unsafe-operation guard does not block trailer command configuration
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-10-08
- Weakness: CWE-78
Description
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.
Affected products
- simple-git: from 3.15.0 before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: simple-git 4.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/steveukx/git-js/commit/d762810c13b331ff1e5eb24c0b434646d2a8d1b3
- https://github.com/steveukx/git-js/pull/1198
- https://github.com/steveukx/git-js/releases/tag/simple-git@4.0.1
- https://github.com/steveukx/git-js/security/advisories/GHSA-x6jw-m9v5-85vh
Get alerted when CVE-2026-102828 or the next vulnerability affects your stack