What’s Vulnerable › Vulnerabilities
CVE-2026-102829: simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection
- Severity: critical (CVSS 9.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-09-30
- Weakness: CWE-78
Description
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it as allowUnsafeEditor. A consuming application that forwards attacker-influenced environment values can therefore allow Git to invoke an attacker-selected editor during operations such as commit amendment or interactive rebase when no higher-priority editor setting overrides VISUAL and Git's terminal prerequisites are met. The executable runs with the privileges of the Node.js process. This issue is fixed in argv-parser 2.0.1.
Affected products
- simple-git: before 2.0.1
References
- https://github.com/steveukx/git-js/commit/68874c239f0c7a87f4a68c3d2c4a0d7c75bb27f4
- https://github.com/steveukx/git-js/pull/1201
- https://github.com/steveukx/git-js/releases/tag/@simple-git/argv-parser@2.0.1
- https://github.com/steveukx/git-js/security/advisories/GHSA-v5rq-49vh-5v5c
Get alerted when CVE-2026-102829 or the next vulnerability affects your stack