What’s Vulnerable › Vulnerabilities
CVE-2026-102938: virtualenv writes prompt values into pyvenv.cfg without sanitizing line boundaries, allowing configuration injection
- Severity: medium (CVSS 5.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-09-30
- Weakness: CWE-93
Description
virtualenv is a tool for creating isolated virtual python environments. Prior to 21.7.11, PyEnvCfg.write() writes prompt values verbatim to the line-oriented pyvenv.cfg format while PyEnvCfg._read_values() parses the file with str.splitlines() and accepts the last value for duplicate keys. An attacker who influences --prompt, VIRTUALENV_PROMPT, or configuration input can insert a recognized line boundary and additional keys, including home, causing consumers to use an attacker-selected base interpreter or corrupted environment metadata. The security impact requires prompt input from outside the operator's trust boundary; directly supplied prompt content primarily corrupts the operator's own environment. This issue is fixed in version 21.7.11.
Affected products
- Pypi Virtualenv: before 21.7.11; 0.8, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9 (+274) — fixed in 21.7.11
- pypa virtualenv: before 21.7.11
How to fix
Upgrade to a fixed version: Pypi Virtualenv 21.7.11. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/virtualenv/commit/a30f995461043acb6cacbf3a890951563ccf7140
- https://github.com/pypa/virtualenv/pull/3247
- https://github.com/pypa/virtualenv/releases/tag/21.7.11
- https://github.com/pypa/virtualenv/security/advisories/GHSA-9h9j-4vrj-gf7g
Get alerted when CVE-2026-102938 or the next vulnerability affects your stack