What’s Vulnerable › Vulnerabilities
CVE-2026-103006: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-09
- Weakness: CWE-674
Description
Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to Denial of Service via a specially crafted, deeply nested request submitted to the aggregation feature of the search API. Elasticsearch contains an uncontrolled recursion weakness in its search aggregation processing. An authenticated user with read access to a single index can submit a specially crafted request containing deeply nested aggregation definitions. Processing this request triggers unbounded recursive execution that exhausts the server process's available resources, causing the affected node to terminate. The node does not recover automatically and requires manual intervention to restore service.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.21; from 9.0.0 before 9.4.6; from 9.5.0 before 9.5.2 — fixed in 8.19.21, 9.4.6, 9.5.2
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.21, 9.4.6, 9.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103006 or the next vulnerability affects your stack