What’s Vulnerable › Vulnerabilities
CVE-2026-103007: Incorrect Authorization in Elasticsearch Leading to Privilege Escalation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-09
- Weakness: CWE-863
Description
Incorrect Authorization (CWE-863) in Elasticsearch can lead to Privilege Escalation via a delegated administrative privilege whose scope is not fully enforced during authorization checks. Elasticsearch contains an incorrect authorization weakness in a configurable, non-default privilege that lets an administrator delegate limited role-management capability to another user, scoped to specific indices. The authorization check that enforces this scoping does not correctly account for a role-definition setting that can expand the matched index set. A user holding this delegated privilege with a broadly-scoped index pattern can exploit this inconsistency by updating their own assigned role to gain access to indices that should remain restricted, including internal security data. This can enable further escalation up to full administrative control of the cluster.
Affected products
- Elasticsearch: from 8.16.0 before 8.19.22; from 9.0.0 before 9.4.7; from 9.5.0 before 9.5.4 — fixed in 8.19.22, 9.4.7, 9.5.4
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.22, 9.4.7, 9.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103007 or the next vulnerability affects your stack