What’s Vulnerable › Vulnerabilities
CVE-2026-103008: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-09
- Weakness: CWE-674
Description
Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to Denial of Service via a specially crafted request that causes the server to construct and process a deeply nested data structure with no bound on recursion depth. Elasticsearch contains an uncontrolled recursion weakness in how it builds and serializes geometry values produced by scripted runtime fields. Unlike geometry supplied as text, which is subject to a nesting-depth limit, geometry constructed from a script's output is not bounded. An authenticated user with read access to a single index can submit a request defining such a field with a script that produces a deeply nested structure. Processing this request recurses past the available stack space, causing the affected node to terminate. The node does not recover automatically on all deployments and may require manual intervention to restore service.
Affected products
- Elasticsearch: from 8.12.0 before 8.19.23; from 9.0.0 before 9.4.8; from 9.5.0 before 9.5.5 — fixed in 8.19.23, 9.4.8, 9.5.5
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.23, 9.4.8, 9.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103008 or the next vulnerability affects your stack