What’s Vulnerable › Vulnerabilities
CVE-2026-103056: AiSOC 7.2.0 before 12.0.0 Command Injection via CrowdStrike RTR
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-09-30
- Weakness: CWE-78
Description
AiSOC versions 7.2.0 before 12.0.0 contain a command injection vulnerability in the actions service that builds CrowdStrike Real Time Response command strings by interpolating unescaped action parameters in crowdstrike_rtr.py and endpoint.py. Authenticated users can inject single quotes into file_path, path, script_name, or script_args parameters to break out of quoted arguments and execute arbitrary commands on managed endpoints with SYSTEM or root privileges.
Affected products
- beenuar AiSOC: from 7.2.0 before 12.0.0 — fixed in 12.0.0
How to fix
Upgrade to a fixed version: beenuar AiSOC 12.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/beenuar/AiSOC/blob/v11.2.0/services/actions/app/clients/crowdstrike_rtr.py#L273
- https://github.com/beenuar/AiSOC/blob/v11.2.0/services/actions/app/executors/endpoint.py#L442
- https://github.com/beenuar/AiSOC/commit/dac39723404130312daba15d42d19114f09f75b2
- https://github.com/beenuar/AiSOC/releases/tag/v12.0.0
- https://github.com/beenuar/AiSOC/security/advisories/GHSA-7q37-2wfw-xrx7
- https://www.vulncheck.com/advisories/aisoc-7.2.0-before-12.0.0-command-injection-via-crowdstrike-rtr
- https://github.com/beenuar/AiSOC/security/advisories/GHSA-7q37-2wfw-xrx7
Get alerted when CVE-2026-103056 or the next vulnerability affects your stack