What’s Vulnerable › Vulnerabilities
CVE-2026-103111
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-04
- Weakness: CWE-787
Description
PCRE2 before 10.49, when there is an attacker-controlled regular expression and certain JIT API usage, allows an out-of-bounds write with arbitrary data.
Affected products
- PCRE2: before 10.49 — fixed in 10.49
How to fix
Upgrade to a fixed version: PCRE2 10.49. Check the vendor advisory for mitigations.
References
- https://github.com/PCRE2Project/pcre2/security/advisories/GHSA-r9hj-j2rw-4q3m
- https://lists.debian.org/debian-lts-announce/2026/10/msg00008.html
- https://github.com/PCRE2Project/pcre2/security/advisories/GHSA-r9hj-j2rw-4q3m
Get alerted when CVE-2026-103111 or the next vulnerability affects your stack