What’s Vulnerable › Vulnerabilities
CVE-2026-103223
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-20
- Weakness: CWE-789
Description
In Eclipse Vert.x versions [4.0.0, 4.5.34] or [5.0.0,5.0.12] or [5.1.0,5.1.9] or [5.2.0, 5.2.0], the PostgreSQL message decoder reads the 4-byte message length field from the PostgreSQL wire protocol without any maximum validation. A malicious, compromised, or man-in-the-middle PostgreSQL server can send a message header with the length field set to an extremely large value (up to Integer.MAX_VALUE), causing the decoder to accumulate subsequent TCP data into a composite buffer without bound, leading to unbounded memory allocation on the client and an out-of-memory crash. This occurs before authentication completes. The impacted component is io.vertx:vertx-pg-client.
Affected products
- Eclipse Foundation Eclipse Vert.x: from 4.5.0 before 4.5.35; from 5.0.0 before 5.1.10; 5.2.0 — fixed in 4.5.35, 5.1.10
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Vert.x 4.5.35, 5.1.10. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-vertx/vertx-sql-client/security/advisories/GHSA-hm2j-xp3c-jff2
- https://gitlab.eclipse.org/security/cve-assignment/-/work_items/354
Get alerted when CVE-2026-103223 or the next vulnerability affects your stack