What’s Vulnerable › Vulnerabilities
CVE-2026-103241: vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-06
- Weakness: CWE-404
Description
A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.
Affected products
- vllm-project vllm: through 0.26.0
References
- https://gist.github.com/Yunzez/8e98d656aa667095b513161eb056d28e
- https://github.com/vllm-project/vllm/
- https://github.com/vllm-project/vllm/commit/3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9
- https://github.com/vllm-project/vllm/issues/50927
- https://github.com/vllm-project/vllm/pull/54303
- https://github.com/vllm-project/vllm/releases/tag/v0.29.1rc0
- https://vuldb.com/cve/CVE-2026-103241
- https://vuldb.com/submit/956250
- https://vuldb.com/vuln/411965
- https://vuldb.com/vuln/411965/cti
Get alerted when CVE-2026-103241 or the next vulnerability affects your stack