What’s Vulnerable › Vulnerabilities
CVE-2026-103244: ground-station before 0.8.0 Authentication Bypass via setup.restore
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-306
Description
ground-station versions before 0.8.0 contain an authentication bypass vulnerability in the setup.restore command that allows unauthenticated attackers to execute arbitrary SQL during first-run setup mode. Attackers can invoke setup.restore via Socket.IO to plant admin users and forged session tokens, then authenticate as administrator without credentials for complete application takeover.
Affected products
- sgoudelis ground-station: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: sgoudelis ground-station 0.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/sgoudelis/ground-station/commit/940df2128e57fa779d0ddee2d9726bd829fc61e1
- https://github.com/sgoudelis/ground-station/security/advisories/GHSA-3mqj-q84c-crjq
- https://www.vulncheck.com/advisories/ground-station-before-0.8.0-authentication-bypass-via-setup-restore
- https://github.com/sgoudelis/ground-station/security/advisories/GHSA-3mqj-q84c-crjq
Get alerted when CVE-2026-103244 or the next vulnerability affects your stack