What’s Vulnerable › Vulnerabilities

CVE-2026-103246: n8n before 2.39.6 and 2.40.x before 2.40.1 Credential Disclosure via Node-Tool Introspection

Description

n8n versions before 2.39.6 and 2.40.0 before 2.40.1 fail to validate credential ownership during inline agent node-tool introspection. Attackers can reference arbitrary credential IDs to decrypt and exfiltrate plaintext secrets to attacker-controlled hosts without ownership verification.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 2.39.6, 2.40.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-103246 or the next vulnerability affects your stack