What’s Vulnerable › Vulnerabilities
CVE-2026-103247: n8n before 1.123.80 Credential Tampering via Duplicate Node IDs
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-639
Description
n8n versions before 1.123.80 contain a credential tampering vulnerability where duplicate node IDs bypass the workflow credential tamper guard. Attackers with editor access to shared workflows can exploit mismatched node ID and name matching to retain victim credentials and redirect secrets to attacker-controlled hosts.
Affected products
- n8n-io n8n: before 1.123.80 — fixed in 1.123.80
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.80. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-7gjv-rcf8-x5qc
- https://www.vulncheck.com/advisories/n8n-before-1.123.80-credential-tampering-via-duplicate-node-ids
Get alerted when CVE-2026-103247 or the next vulnerability affects your stack