What’s Vulnerable › Vulnerabilities

CVE-2026-103248: n8n before 1.123.80, 2.39.6, and 2.40.1 PostgREST Filter Injection via Supabase

Description

n8n versions before 1.123.80, from 2.0.0 before 2.39.6, and from 2.40.0 before 2.40.1 contain a filter injection vulnerability in the Supabase node's Filters (String) mode that fails to escape field values. Attackers can inject filter expressions from untrusted input to read all table rows, update all records, or delete entire tables in a single request.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.80, 2.39.6, 2.40.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-103248 or the next vulnerability affects your stack