What’s Vulnerable › Vulnerabilities

CVE-2026-103250: n8n before 1.123.80, 2.39.6, and 2.40.1 NoSQL Injection via MongoDB Chat Memory

Description

n8n versions before 1.123.80, from 2.0.0 before 2.39.6, and from 2.40.0 before 2.40.1 contain a NoSQL injection vulnerability in the MongoDB Chat Memory node that fails to validate the sessionId parameter. Unauthenticated attackers can supply MongoDB query operators in the sessionId field to access conversation histories from other users and perform unauthorized write and delete operations.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.80, 2.39.6, 2.40.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-103250 or the next vulnerability affects your stack