What’s Vulnerable › Vulnerabilities
CVE-2026-103251: n8n before 1.123.80, 2.39.6, and 2.40.1 Package Install Validation Bypass via PubSub
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-862
Description
n8n versions before 1.123.80, from 2.0.0 before 2.39.6, and from 2.40.0 before 2.40.1 contain a validation bypass vulnerability in the community package installation handler for queue mode deployments. Attackers with Redis write access can bypass name validation, permission checks, checksum verification, and npm safety checks to install arbitrary npm packages across all cluster instances without authentication.
Affected products
- n8n-io n8n: before 1.123.80; from 2.0.0 before 2.39.6; from 2.40.0 before 2.40.1 — fixed in 1.123.80, 2.39.6, 2.40.1
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.80, 2.39.6, 2.40.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-fmmv-p585-7c8x
- https://www.vulncheck.com/advisories/n8n-before-1.123.80-2.39.6-and-2.40.1-package-install-validation-bypass-via-pubsub
Get alerted when CVE-2026-103251 or the next vulnerability affects your stack