What’s Vulnerable › Vulnerabilities
CVE-2026-103256: n8n before 2.39.6 and 2.40.x before 2.40.1 Credentials Leak via preAuthentication Hook
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-522
Description
n8n versions before 2.39.6 and 2.40.0 before 2.40.1 contain a credentials leak vulnerability in the Wekan and Baserow username-and-password credentials that sends unencrypted passwords to unvalidated hosts. Attackers with credential update permissions can modify the host field to receive account passwords at arbitrary hosts, bypassing domain validation controls.
Affected products
- n8n-io n8n: before 2.39.6; from 2.40.0 before 2.40.1 — fixed in 2.39.6, 2.40.1
How to fix
Upgrade to a fixed version: n8n-io n8n 2.39.6, 2.40.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-gx6g-2hm7-c4xf
- https://www.vulncheck.com/advisories/n8n-before-2.39.6-and-2.40-x-before-2.40.1-credentials-leak-via-preauthentication-hook
Get alerted when CVE-2026-103256 or the next vulnerability affects your stack