What’s Vulnerable › Vulnerabilities

CVE-2026-103257: n8n before 1.123.80, 2.39.6, and 2.40.1 Path Traversal via n8n Node

Description

n8n versions before 1.123.80, from 2.0.0 before 2.39.6, and from 2.40.0 before 2.40.1 contain a path traversal vulnerability in the n8n node that fails to validate resource identifiers. Attackers can craft malicious resource IDs to redirect API calls to unintended resources, allowing unauthorized access to workflows, executions, and credential secrets within the API key's scope.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.80, 2.39.6, 2.40.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-103257 or the next vulnerability affects your stack