What’s Vulnerable › Vulnerabilities

CVE-2026-103259: n8n before 2.39.6 and 2.40.x before 2.40.1 Session Token Leak via Dynamic Credentials

Description

n8n versions before 2.39.6 and 2.40.0 before 2.40.1 contain a session token leakage vulnerability in the Dynamic Credentials authorize and revoke endpoints. Attackers with resolver registration capability can capture collaborators' session tokens by setting a fallback resolver to an attacker-controlled endpoint during the account connection flow, enabling unauthorized credential access.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 2.39.6, 2.40.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-103259 or the next vulnerability affects your stack