What’s Vulnerable › Vulnerabilities
CVE-2026-103261: Tornado before 6.5.9 Denial of Service via Query String
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-770
Description
Tornado before 6.5.9 fails to limit the number of query string fields in HTTPServerRequest.__init__, allowing remote attackers to cause event-loop stalling by sending requests with thousands of query parameters. Attackers can send unauthenticated GET requests with unbounded query-string field counts to degrade response times for all clients sharing the same IOLoop.
Affected products
- Pypi Tornado: before 6.5.9; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+78) — fixed in 6.5.9
- tornadoweb tornado: before 6.5.9 — fixed in 6.5.9
How to fix
Upgrade to a fixed version: Pypi Tornado 6.5.9; tornadoweb tornado 6.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/commit/03945136ea9746eccf61caf88edae39642e59c93
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-3hv7-mjh2-fv65
- https://www.vulncheck.com/advisories/tornado-before-6.5.9-denial-of-service-via-query-string
Get alerted when CVE-2026-103261 or the next vulnerability affects your stack