What’s Vulnerable › Vulnerabilities
CVE-2026-103262: Tornado before 6.5.9 Denial of Service via CurlAsyncHTTPClient
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-06
- Weakness: CWE-409
Description
Tornado versions before 6.5.9 contain an unbounded memory accumulation vulnerability in CurlAsyncHTTPClient that allows remote attackers to cause denial of service by sending a compressed response. Attackers can send a gzip-encoded decompression bomb that accumulates in memory without size limits, causing the application process to be killed by out-of-memory conditions.
Affected products
- Pypi Tornado: before 6.5.9; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+78) — fixed in 6.5.9
- tornadoweb tornado: before 6.5.9 — fixed in 6.5.9
How to fix
Upgrade to a fixed version: Pypi Tornado 6.5.9; tornadoweb tornado 6.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/commit/e412435febba4569c552c5c9054f1bf92bd171a9
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-chx6-46f5-w4vp
- https://www.vulncheck.com/advisories/tornado-before-6.5.9-denial-of-service-via-curlasynchttpclient
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-chx6-46f5-w4vp
Get alerted when CVE-2026-103262 or the next vulnerability affects your stack