What’s Vulnerable › Vulnerabilities
CVE-2026-103281: Ghost 3.23.0 before 6.23.0 API Key Exposure via Admin API
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-201
Description
Ghost (npm package 'ghost') versions from 3.23.0 up to, but not including, 6.23.0 expose API keys to users with low-privilege staff accounts. An authenticated low-privilege staff user can read API keys returned by the Admin API, which are intended to be available only to higher-privileged users.
Affected products
- TryGhost Ghost: from 3.23.0 before 6.23.0 — fixed in 6.23.0
How to fix
Upgrade to a fixed version: TryGhost Ghost 6.23.0. Check the vendor advisory for mitigations.
References
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-q98w-jm4q-wch7
- https://www.vulncheck.com/advisories/ghost-3.23.0-before-6.23.0-api-key-exposure-via-admin-api
Get alerted when CVE-2026-103281 or the next vulnerability affects your stack