What’s Vulnerable › Vulnerabilities
CVE-2026-103287: Ghost 1.18.0 before 6.27.0 Server-Side Request Forgery via Webhook
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-06
- Weakness: CWE-918
Description
Ghost versions 1.18.0 before 6.27.0 contain a server-side request forgery vulnerability in the webhooks feature that allows staff users to probe internal hosts. Attackers with staff privileges can craft webhook requests to access internal network resources from the Ghost server.
Affected products
- TryGhost Ghost: from 1.18.0 before 6.27.0 — fixed in 6.27.0
How to fix
Upgrade to a fixed version: TryGhost Ghost 6.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-354h-gmhv-mr9c
- https://www.vulncheck.com/advisories/ghost-1.18.0-before-6.27.0-server-side-request-forgery-via-webhook
Get alerted when CVE-2026-103287 or the next vulnerability affects your stack