What’s Vulnerable › Vulnerabilities
CVE-2026-103307: Walletdoc Payment Gateway for WooCommerce < 1.8.5 - Unauthenticated SQLi and Order Payment Forgery via Webhook
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-14
- Weakness: CWE-89
Description
The Walletdoc Payment Gateway for WooCommerce WordPress plugin before 1.8.5 does not properly sanitize and escape user input before using it in a SQL statement, and verifies its payment webhook with a signing secret that is empty by default, allowing unauthenticated attackers to perform SQL injection attacks and to mark arbitrary orders as paid.
Affected products
- Walletdoc Payment Gateway for WooCommerce: before 1.8.5 — fixed in 1.8.5
How to fix
Upgrade to a fixed version: Walletdoc Payment Gateway for WooCommerce 1.8.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103307 or the next vulnerability affects your stack