What’s Vulnerable › Vulnerabilities
CVE-2026-103308: Visma Pay for WooCommerce < 1.2.2 - Unauthenticated Payment Bypass and Order Data Disclosure via Gateway Return Endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-14
- Weakness: CWE-345
Description
The Visma Pay for WooCommerce WordPress plugin before 1.2.2 does not verify the authenticity of payment gateway return requests, relying on a merchant secret that is empty on a store which has not entered its credentials, allowing unauthenticated attackers to mark arbitrary orders as paid and to disclose the name, email address and postal address of any order's customer.
Affected products
- Visma Pay for WooCommerce: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Visma Pay for WooCommerce 1.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103308 or the next vulnerability affects your stack