What’s Vulnerable › Vulnerabilities
CVE-2026-103309: GPTranslate < 2.34.14 - Unauthenticated Stored XSS via REST API Translation Storage
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-79
Description
The GPTranslate WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.
Affected products
- GPTranslate: before 2.34.14 — fixed in 2.34.14
How to fix
Upgrade to a fixed version: GPTranslate 2.34.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103309 or the next vulnerability affects your stack