What’s Vulnerable › Vulnerabilities
CVE-2026-103324: Cardinity Payment Gateway for WooCommerce 3.2.6 - 3.4.1 - Unauthenticated Arbitrary Order Payment Forgery via Empty-Default Project Secret
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-15
- Weakness: CWE-345
Description
The Cardinity Payment Gateway for WooCommerce WordPress plugin before 3.4.2 does not properly verify the authenticity of the payment notifications it receives, as the secret used to sign them is empty by default, allowing unauthenticated attackers to forge an approved-payment notification and mark arbitrary orders as paid, or force them to failed.
Affected products
- Cardinity Payment Gateway for WooCommerce: from 3.2.6 before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: Cardinity Payment Gateway for WooCommerce 3.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103324 or the next vulnerability affects your stack