What’s Vulnerable › Vulnerabilities
CVE-2026-103413: Apache Camel Karavan: unvalidated Kubernetes resources applied from a project's kubernetes.yaml
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-09 · updated 2026-10-15
- Weakness: CWE-20
Description
Improper input validation vulnerability in Apache Camel Karavan. When a deployment was started, Karavan unmarshalled a project's `kubernetes.yaml` and applied every resource it contained to the cluster without restricting the resource kinds, without rejecting security-sensitive pod options, and without pinning the target namespace. An authenticated user of any role could therefore have Karavan apply arbitrary Kubernetes resources within the reach of its service account, including pods requesting hostNetwork, hostPID, hostIPC, hostPath volumes, host ports, privileged containers, privilege escalation or added capabilities. This issue affects Apache Camel Karavan: from 4.0.0 before 4.22.1. Users are recommended to upgrade to version 4.22.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Camel Karavan: from 4.0.0 before 4.22.1 — fixed in 4.22.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Camel Karavan 4.22.1. Check the vendor advisory for mitigations.
References
- https://camel.apache.org/security/CVE-2026-103413.html
- https://github.com/apache/camel-karavan/commit/a773db372eab9f180110ad6129d58004a1bce571
- http://www.openwall.com/lists/oss-security/2026/10/09/17
Get alerted when CVE-2026-103413 or the next vulnerability affects your stack