What’s Vulnerable › Vulnerabilities
CVE-2026-103514: WP 2FA < 4.1.0 - Two-Factor Authentication Bypass via TOTP Code Replay
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-03 · updated 2026-10-06
- Weakness: CWE-287
Description
The WP 2FA WordPress plugin before 4.1.0 does not invalidate a time-based one-time passcode once it has been used, allowing an attacker who knows an account's password and has observed a valid code within its validity window to replay it and bypass two-factor authentication, including on administrator accounts.
Affected products
- WP 2FA: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: WP 2FA 4.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103514 or the next vulnerability affects your stack