What’s Vulnerable › Vulnerabilities
CVE-2026-103515: Incorrect Authorization in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 19.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when an instance administrator locked a group's Duo availability, an authenticated user with group Owner permissions could have re-enabled AI-backed data egress to a third-party service for that group and its descendant projects, due to insufficient granularity of the admin-lock enforcement controls.
Affected products
- GitLab: from 19.2.0 before 19.3.6; from 19.4.0 before 19.4.3; 19.5.0 (and their updates) — fixed in 19.3.6, 19.4.3
- GitLab: from 19.2 before 19.3.6; from 19.4 before 19.4.3; from 19.5 before 19.5.1 — fixed in 19.3.6, 19.4.3, 19.5.1
How to fix
Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-5-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/631564
- https://hackerone.com/reports/3871692
Get alerted when CVE-2026-103515 or the next vulnerability affects your stack