What’s Vulnerable › Vulnerabilities
CVE-2026-103552: Apache Directory LDAP API: A unbound client can send a deeply nested search filter that overflows the stack in the server's decoder
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-121
Description
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache Directory LDAP API: from 1.2.0 before 1.2.9 — fixed in 1.2.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Directory LDAP API 1.2.9. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/fn3bwknn57266hx66w9vv6b4k8rfwcx7
- http://www.openwall.com/lists/oss-security/2026/10/02/4
Get alerted when CVE-2026-103552 or the next vulnerability affects your stack