What’s Vulnerable › Vulnerabilities
CVE-2026-103663: Path Traversal leading to Remote Code Execution in Ollama
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-23
Description
Ollama is vulnerable to path traversal in the `/api/pull` endpoint due to insufficient validation of layer digests by the `digestToPath` function. An unauthenticated remote attacker can specify a path traversal sequence as a layer digest, causing a malicious binary to be written outside the model store. Critically if the server process has write access to `/usr/lib/ollama` (the default in most Ollama Docker images), an attacker can write the malicious file to that directory. On the next server restart, the file is loaded and executed, resulting in remote code execution as root. This issue was fixed in version 0.35.0.
Affected products
- Ollama: from 0.34.2 before 0.35.0 — fixed in 0.35.0
How to fix
Upgrade to a fixed version: Ollama 0.35.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103663 or the next vulnerability affects your stack