What’s Vulnerable › Vulnerabilities
CVE-2026-103877: Apache Directory LDAP API: Unsafe loading of Java code from LDAP schema elements
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-07
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache Directory LDAP API: from 2.1.0 before 2.1.9 — fixed in 2.1.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Directory LDAP API 2.1.9. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/sys8l881blqfgoc3o724jl32bmjl8pvw
- http://www.openwall.com/lists/oss-security/2026/10/02/5
Get alerted when CVE-2026-103877 or the next vulnerability affects your stack