What’s Vulnerable › Vulnerabilities
CVE-2026-103880: Apache Directory LDAP API: Denial of service via excessive bcrypt cost factor in stored passwords
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-05
- Weakness: CWE-405
Description
Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. Storing a password using the bcrypt algorithm with a high force like 30 in a LDAP server that supports this algorithm will cause the server CPU to run for hours checking the credentials. A bounded cost should be enforced to avoid a server DOS. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache Directory LDAP API: from 2.1.0 before 2.1.9 — fixed in 2.1.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Directory LDAP API 2.1.9. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/39q63m54v9go6xj7pqj7q18c3szn9go4
- http://www.openwall.com/lists/oss-security/2026/10/02/7
Get alerted when CVE-2026-103880 or the next vulnerability affects your stack