What’s Vulnerable › Vulnerabilities
CVE-2026-103885: Apache Directory LDAP API: Denial of service via crafted telephone number values
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-08
- Weakness: CWE-400
Description
Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. A LDAP server using the LDAP API (like Apache DS) may consume 100% of a CPU core indefinitely when processing some badly crafted Telephone Numbers. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache Directory LDAP API: from 2.1.0 before 2.1.9 — fixed in 2.1.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Directory LDAP API 2.1.9. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/wjt9p1l123v6b3zd5dg41f8lfrgy5vg9
- http://www.openwall.com/lists/oss-security/2026/10/02/8
Get alerted when CVE-2026-103885 or the next vulnerability affects your stack