What’s Vulnerable › Vulnerabilities
CVE-2026-103904: Stored XSS Vulnerability in JTL-Shop
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-79
Description
The public consent endpoint of JTL-Shop accepts arbitrary consent names from unauthenticated visitors without validating them against the configured consent items. These names are stored in the consent statistics and rendered without output encoding in the administration backend. An unauthenticated remote attacker can thereby inject script code that is executed in the browser session of an administrator viewing the consent statistics page, allowing actions to be performed with the administrator's privileges.
Affected products
- JTL-Software GmbH JTL-Shop: from 5.4.0 before 5.6.5; from 5.7.0 before 5.7.5; from 5.8.0 before 5.8.2 — fixed in 5.6.5, 5.7.5, 5.8.2
How to fix
Upgrade to a fixed version: JTL-Software GmbH JTL-Shop 5.6.5, 5.7.5, 5.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-103904 or the next vulnerability affects your stack