What’s Vulnerable › Vulnerabilities
CVE-2026-103956: Missing authentication for critical function in Loom for AWS
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-10-02 · updated 2026-10-06
- Weakness: CWE-306
Description
Missing authentication for critical function in the authentication dependency in Loom for AWS before 1.6.1 allowed remote actors to obtain super-admin authority over the agent control plane, including registering tool servers, reading stored integration credentials, and rewriting the IAM role policies attached to managed agent roles, via any request to the application API in a deployment where no identity provider is configured. To remediate this issue, users should upgrade to version 1.6.1 or later.
Affected products
- AWS loom: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: AWS loom 1.6.1. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-124-aws/
- https://github.com/awslabs/loom/releases/tag/v1.6.1
- https://github.com/awslabs/loom/security/advisories/GHSA-vgmj-998f-r8mp
Get alerted when CVE-2026-103956 or the next vulnerability affects your stack