What’s Vulnerable › Vulnerabilities
CVE-2026-103958: Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-06
- Weakness: CWE-918
Description
Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS before 1.7.0 might allow an authenticated remote user to obtain the credentials of the application's own container role and to read responses from arbitrary internal network locations, via a crafted connection address supplied when registering, updating or testing a tool server or remote agent. To remediate this issue, users should upgrade to version 1.7.0 or later.
Affected products
- AWS loom: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: AWS loom 1.7.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-124-aws/
- https://github.com/awslabs/loom/releases/tag/v1.7.0
- https://github.com/awslabs/loom/security/advisories/GHSA-w6g6-h8pv-6mc7
Get alerted when CVE-2026-103958 or the next vulnerability affects your stack