What’s Vulnerable › Vulnerabilities
CVE-2026-104126: JumpServer: Ansible Automation Template Rendering Allows Unsafe Lookup Plugin Invocation
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-16
- Weakness: CWE-94
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.10.17-lts, JumpServer's Ansible-based automation rendering can evaluate attacker-controlled template expressions from users who have permission to create or execute affected automation tasks. Crafted content can invoke sensitive Ansible lookup behavior, including file, pipe, env, and password lookups, within the Ansible execution context, which can disclose files or environment values and may permit limited command execution under the privileges of the automation process. The issue does not provide unauthenticated access or direct access to unrelated JumpServer assets. This issue is fixed in version 4.10.17-lts.
Affected products
- jumpserver: before 4.10.17
References
- https://github.com/jumpserver/jumpserver/commit/cc57ba0de5f6015746fae11cfc62402b11618e59
- https://github.com/jumpserver/jumpserver/pull/16886
- https://github.com/jumpserver/jumpserver/releases/tag/v4.10.17
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-gr5x-5c4h-867g
Get alerted when CVE-2026-104126 or the next vulnerability affects your stack