What’s Vulnerable › Vulnerabilities
CVE-2026-104414: Ghost from 2.5.0 before 6.64.0 Stored XSS via oEmbed Photo Responses
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-79
Description
Ghost from 2.5.0 before 6.64.0 contains a stored cross-site scripting vulnerability that allows attackers to inject untrusted scripts into post content via oEmbed photo responses. Attackers can host malicious oEmbed photo responses so that embedding their URL stores scripts that run in the Ghost editor, published site, and newsletter emails, compromising staff admin sessions.
Affected products
- TryGhost Ghost: from 2.5.0 before 6.64.0 — fixed in 6.64.0
How to fix
Upgrade to a fixed version: TryGhost Ghost 6.64.0. Check the vendor advisory for mitigations.
References
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-v3xr-g6p2-fvgv
- https://www.vulncheck.com/advisories/ghost-from-2.5.0-before-6.64.0-stored-xss-via-oembed-photo-responses
Get alerted when CVE-2026-104414 or the next vulnerability affects your stack